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3 Sudoku Solver V1.0J

1 Introduction

1.1  Sudoku Solver V1.0 Java
Welcome to the Sudoku solver, a free utility provided by DeadMan's Handle Ltd as an aid to
Sudoku puzzle solvers everywhere. The program is straightforward to run, and will solve any
puzzle almost instantaneously. It also allows you to save and load puzzles and solutions, and eMalil
then to recipients. This is the Java version, and should work on any system that has the Sun Java
Runtime Environment installed, including Windows, Mac OS and Linux.
This version is roughly equivalent to the V1.3 Windows native version, except it has no training
capability. In addition, the help file is provided separately.
We hope you enjoy the program, and please contact us should you need any further help at any
time.
The DMH Development Team
DeadMan's Handle Ltd
www.sudoku-solver.com

1.2 Installation and Running

Before installing, please ensure you have a recent version of the Java Runtime Environment on
your system, available from www.sun.com. The version should be 1.4 or later.

Simply place the file SudokuSolver.jar in a known folder.

Under Windows, you can right-click on the file and select Copy, and then right-click on your
desktop and select Paste Shortcut - a shortcut will be placed on your desktop. Double-clicking on
the shortcut will run the program. Or you can just double-click on the program itself.

Under other systems, you must make sure that the system has the Java bin folder on the system
path. You can then go the folder, and from a command prompt give the command:

> javaw -jar sudokusolver.jar

Of course, your system may support just double-clicking on the program (it will depend on your
operating system and Java environment).

Note that first time it runs you may get a warning that files are being recreated. This is entirely
normal and can be ignored.

This Java version is a developmental version - we would be grateful for any comments, especially
on how it runs on different platforms.
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2
2.1

2.2

Using the Solver

The Solver Screen

When you start up the Soduko Solver, you will be presented with the following screen:

File Rumn Mail Help

HoRd2hE

0/0/0jojo/o]oloj0
0/0/0j0l0/0j0/0l0

Beneath the title are the following items:

The menus.

The quick speed buttons, that reproduce all bar one of the menu items for quick access.
The Sudoku entry and results grid.

A progress bar at the bottom left.

To the right of the progress bar, a an area where the system will give status messages.

arwdpE

The last two items are read-only: they simply provide information on how quickly the puzzle is being
solved and give you information when certain activities are complete.

You will use this form to enter the puzzles, and get the solutions. The form also allows you to save
and load puzzles, and send them as eMails.

The Menu and Buttons

This section describes the use of the menus. Each menu entry will be discussed with its equivalent
button, except in the cases where there is no button equivalent. All submenu items have an
associated function key: pressing the function key will activate the menu item directly.

The File Menu

There are four submenu items under the file menu. Each one will be discussed in turn, along with
the different ways of accessing it. The equivalent speed button is shown alongside the submenu
title, which is shown in the form Menu->Submenu.

@ File->New
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Using the Solver

This will clear down the grid and reset the system to the blank state (see the discussion about the
entry and results grid). All displayed values will be 0. The progress bar and status indicator will be
cleared as well. This should always be done before a new puzzle is entered or loaded.

This may be accessed by pressing the F1 key.

@ File->Load Puzzle

This will load a puzzle (or a completed result) which has been previously saved using the Save
Screen option. The files must be in the correct text format. The system will load and display the
puzzle.

The menu entry may also be accessed by pressing F2.

% File->Save Screen

This will save a puzzle or completed result, which can then be reloaded using the Load Puzzle
option. The numbers you see in the grid when the option is selected is what is saved out to the file.
The file is actually just a text file with the numbers simply arranged in a 9 by 9 array representing
the Sudoku grid. You can mail this file (see also the mail options) or incorporate it into a document.
The option may be accessed by pressing F3.

File->Exit

This simply exits the Sudoku Solver program.

This may also be accessed by using F4.

The Run Menu

This has just one submenu: Go.

ﬂ Run->Go

This will take the current grid, and solve it, if it is possible to do so. The system will tell you if the
grid entries are illegal (such as the same number in a row or column). If the puzzle is ambiguous,
then the system will produce the first solution it comes to. See the discussion for further comments
on Sudoku solutions.

This option may be accessed by pressing F5.

The Mail Menu

There are three items in this menu. These provide eMail support, allowing you quickly to send off
solutions (or even puzzles) to friends or magazines (especially in the latter case, where there may
be prizes involved).

2| Vail->Set up eMail

This gives you access to the eMail Template System. This allows you to set up your templates for
eMailing puzzles and solutions.

This may be accessed by pressing F6.

@ Mail->Send eMail
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7 Sudoku Solver V1.0J
This option will take all your eMail template information, and the header information in the header
section, and adds the puzzle or solution that is being displayed in the grid. It then mails it using its
own SMTP client to the recipient(s) nominated in the header. Please note that you must be
connected to the SMTP server (usually either by dial-up or some form of DSL) before selecting this
option as it will time out a while.
You can access this by using F7.
Mail->Save eMail Text
This will combine your eMail template information with the grid information to produce a completed
text message, which can be saved as a file. This is provided for people who are not using an
SMTP mail system: the text can quickly be pulled into a mail and sent off.
This can be accessed by using F8.
The Help Menu
This just provides one options.
Help->About
This just shows a box with some basic program details.
This can be accessed by pressing F10.

2.3  The Entry and Results Grid

The grid is the middle part of the solver screen, which looks as follows:

0/0/0j0[0j0j0[0[0

It basically represents the standard Sudoku grid. A zero in a cell means that there is nothing in it: it
is the same as a blank. The system is set up so that you cannot enter anything except a numeric
digit into the cells.

When you are entering the puzzle, you can enter the data in two ways:
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1. You can move from cell to cell using the Tab key. When you arrive in a cell you will find the
digit highlighted. Simply type the digit you want, you will be moved on to the next field. If you
tab straight through the digit in the cell will remain unaltered. Shift-Tab will move you
backwards through the cells.

2. You can highlight any digit using the mouse and right-click button, and then type in a new digit.

When you have entered a puzzle, you can then save it, using the save option. This will save the
grid as you see it. Thus the usual way to use these options is to enter the puzzle, save it, solve it by
running the solution process, and then save the result.
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The eMail Template System 10

3 The eMail Template System
3.1 The eMail Template Screen

When you select the Mail->Set up eMail menu option on the solver screen, you will be taken to the

eMail template form. This looks as follows:

£ Sudoku Solver ¥1.0J - Mail Setup Al=l_d
File Help
DO B K
Mail Host: | st mailhost corm | User Name: | |
Password: | |
Ter | competiong@magazine.com | Fram: | playerg@mailcliert com |
|

Subject: | Sudoku Entry

Text of mezzage bhefore the solution:

ear 3ir,

Pleaze find my Jawva solution

Text of mezzage after the zolution:

est Begards,

Player

This screen is made up of the following:

There is a menu.

Below this, there is a group of quick access speed buttons.
There is a header section, which has six fields.

There is a text section.

There is then a second text section.

arwdpE

The menu and buttons are discussed elsewhere; here we discuss the fields. These all act as
templates for your puzzle solution messages.

The eMail Header Section
This is comprised of six fields:

1. The first is the Mail Host name (or IP address). This will usually be something like
smtp.hostname.com or smtp.hostname.co.uk. This field must be filled in, as it is how the eMail
gets sent to the host.

2. The second field is the user name field, and the third is the password. These fields are
optional: they are only needed when your SMTP server requires authorization. Most do not. If
they do not, then leave these fields blank.

3. The fourth field is the To: field. You must enter the full mail address of the person (something
like name@host.com). You may put in more than one mail address, separating them with
commas.
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3.2

4. The fifth field is the From: address. You should put in your mail address here.
5. The sixth and last field is the Subject field: what the recipient will see as the mail subject.

The Text Sections

There are two text sections. One will be placed before the grid information, and the other after the
grid information. The idea is that you can have a brief introduction, then the puzzle answer, and
then your signature. This is especially designed for competitions.

How it all Works

All the information you put into the sections is saved in template files. You then do not have to
update them unless you want to: the system is designed for a regular competition that you might be
entering. You can then do a puzzle, and eMail it just by hitting the Send eMail button. The
information will be taken from the templates and the grid, which is holding the solution, and will be
sent off via the SMTP client. Alternatively, you can just generate the text message and then pull it
into another mail client and send it. In this latter case no part of the header template is used in the
text message.

The system is designed to be quick to use. Having set up the templates for a regular competition,

you can just enter the Sudoku puzzle, run the solution process and then eMail the answer to the
predefined address.

The Menu and Buttons

The template screen has a few menus and buttons. Again, most of the menu entries have a
matching speed button and quick access methods.

The File Menu

The file menu has four options, described in this section.

File->New Header

This will clear down the top six header fields, from Mail Host to Subject. This is for when you want
to set up a new template. Note that the system will only maintain one template at a time.

You may also access this by pressing F11.

O] File->New Text

This will clear down the bottom two text fields. Again, this is for when you want to set up new text in
the template.

You may also access this with F12.

% File->Save

This will save all updated information to the templates. Note that you will not be asked for a file
name: the templates are special files that the system keeps track of.

You can access this option with F3.

M File->Return

This will return you to the solver screen. If you have changed any of the information in the fields
you will asked if you wish to discard the changes.
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You can access this option with F4.

The Help Menu

This just provides one option.

Help->About

This just shows a box with some basic program details.

This can be accessed by pressing F10.
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Discussions

Sudoku Solutions

This topic briefly discusses how the DeadMan's Handle Sudoku Solver functions.

When you input a puzzle, the system first scans it to ensure there are no obvious errors (such as
two numbers the same in a row, column or 3x3 box). It will generate a message if there are.

The system will then attempt to solve the puzzle deterministically. For most puzzles this will yield
the solution. For some puzzles the deterministic capability produces no further progress, either
because the puzzle has more than one solution or because it is very subtle. At this point the
system does a structured exploration of solutions, looking for inconsistencies until the solution is
found.

If a solution is possible, then the system will find it almost instantaneously on a modern machine. If
there is more than one solution possible, then the system will return the first solution it finds (as an
experiment, run the solver with all zeros in the grid).

If a solution is not possible, then the system will determine that it cannot find a solution. It will return
a partially completed grid which will still have some zeros in it, and will generate a warning
message. Note that it is possible for the system's initial checks not to be able to identify a problem
with a puzzle: it only appears in the solution attempt. As an example, consider the following partial
fragment of a problem (this is an artificial example):

5

5

Because of the row and column rules, with the positioning of the fives and the one, there is no
possible place for a five in the top-right 3x3 box, which is impossible according to the Sudoku rule.
However, there is nothing in the positioning of the fives and ones that is contradictory in
themselves (ie no two fives are in the same row). It is in such cases that the system will come back
with an incomplete grid and a warning message.
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Licences

Sudoku Solver Licence

The following is the licence for the Sudoku Solver.

1.

Usage. You may install and use the software on any number of machines. You may copy and
distribute the software as long as: (1) no charge is made except for costs in reproducing the
software; (2) you do not modify or alter any part of the program, documentation or distribution
kit.

. Copyright. DeadMan's Handle Ltd owns the title, copyright, and other intellectual property

rights in the software.

Warranty disclaimer. The software and media are provided as seen, without warranty of any
kind. To the maximum extent permitted by applicable law, DeadMan's Handle Ltd disclaims all
warranties and conditions, either express or implied, including but not limited to, implied
warranties and conditions of merchantability, fithess for a particular purpose, and non-
infringement with respect to the software, its output, and media.

Limitation of Liability. DeadMan's Handle Ltd accepts no responsibility for any damage and/or
loss to your data or computer system that may result from the use of the software except to the
extent required by law.
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