1
2
3
5
4
6
8
9
7

Sudoku Solver Manual
Version 1.3

© 2004, 2005 DeadMan's Handle Ltd




Sudoku Solver V1.3

Contents

Part 1

Introduction

SUAOKU SOIVET evvveiiiiieeieeee e
INStallation  ..eeeii e

Using the Solver

The SOIVEr SCIrEEN ...coevvveeeeeeeeeeeee e
The Menu and BUttONS .....oooovveevveiiiieeeeeeeeee e
The Entry and Results Grid .......cccccoooiiiiiiiiiininiiiinen,

The eMail Template System

The eMail Template SCreen .....cccccceevvecvieeveeee e,
The Menu and BUttons .......ccoooeeeiiiiiiiiiiiieeeeeeeeeceeeee,

Discussions

SUdOKU SOIULIONS ..ovveeeiiieeec e
Training MO .....cceviiiieee e

Licences

Sudoku Solver LICENCEe .....ccueeviviieiieiiiiee e
Indy Components LICENCE .....ccuvvveveeeeeeiiiiieeeeee e

Index

© 2004, 2005 DeadMan's Handle Ltd



Part



Sudoku Solver V1.3

1.2

Introduction

Sudoku Solver

Welcome to the Sudoku solver, a free utility provided by DeadMan's Handle Ltd as an aid to
Sudoku puzzle solvers everywhere. The program is straightforward to run, and will solve any
puzzle almost instantaneously. It also allows you to save and load puzzles and solutions, and eMalil
then to recipients.

We hope you enjoy the program, and please contact us should you need any further help at any
time.

The DMH Development Team
DeadMan's Handle Ltd
www.sudoku-solver.com

© 2004, 2005 DeadMan's Handle Ltd

Installation

If you have opted for the full installation program, then simply run the install program
Sudokulnstaller.exe. You will be prompted through the installation process. This installation method
requires that you have the Windows Installer on the system. Note that you can use the 'Add or
Remove Programs' utility to remove the Sudoku Solver if you use this installation mechanism.

You can also download the distribution kit as a Zip file, Sudokulnstall.Zip. Simply copy the files to a
folder and create any required icons on the desktop or start menu. To remove the program, simply
delete the folder and any icons that you have created.

© 2004, 2005 DeadMan's Handle Ltd
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2
2.1

2.2

Using the Solver

The Solver Screen

When you start up the Sudoku Solver, you will be presented with the following screen:
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Beneath the title are the following items:

The menus.

The quick speed buttons, that reproduce all important menu items for quick access.

The Sudoku entry and results grid.

A progress bar at the bottom left.

To the right of the progress bar, a blank space where the system will give status messages.

arwdpE

The last two items are read-only: they simply provide information on how quickly the puzzle is being
solved and give you information when certain activities are complete. It should be noted that on
modern machines the progress bar is effectively redundant unless you are in training mode: the
solution will be provided almost immediately.

You will use this form to enter the puzzles, and get the solutions. The form also allows you to save
and load puzzles, and send them as eMails.

The Menu and Buttons

This section describes the use of the menus. Each menu entry will be discussed with its equivalent
button (except in the cases where there are no equivalents). All menus have accelerator keys,
indicated by the underlined letter: hitting the Alt key plus the letter will activate the menu item (so to
load a puzzle one hits Alt-F then Alt-L). If you cannot see the underlined keys under Windows XP
or 2000, check that you have not hidden the underlined keys (an option under the display settings).
In addition, all submenu items have an associated function key: pressing the function key will
activate the menu item directly.

The File Menu

There are four submenu items under the file menu. Each one will be discussed in turn, along with
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the different ways of accessing it. The equivalent speed button is shown alongside the submenu
title, which is shown in the style Menu->Submenu.

@ File->New

This will clear down the grid and reset the system to the blank state (see the discussion about the
entry and results grid). All displayed values will be 0. The progress bar and status indicator will be
cleared as well. This should always be done before a new puzzle is entered or loaded.

This may be accessed by hitting Alt-F then Alt-N, or by pressing the F1 key.

@ File->Load Puzzle

This will load a puzzle (or a completed result) which has been previously saved using the Save
Screen option. The files must be in the correct text format. The system will load and display the
puzzle.

The menu entry may also be accessed by Alt-F then Alt-L, or by pressing F2.

% File->Save Screen

This will save a puzzle or completed result, which can then be reloaded using the Load Puzzle
option. The numbers you see in the grid when the option is selected is what is saved out to the file.
The file is actually just a text file with the numbers simply arranged in a 9 by 9 array representing
the Sudoku grid. You can mail this file (see also the mail options) or incorporate it into a document.

The option may be accessed via Alt-F then Alt-S, or by pressing F3.

X File->Exit
This simply exits the Sudoku Solver program.

This may also be accessed via Alt-F then Alt-E, or by using F4.

The Run Menu

This has just two submenus: Go and Training.

ﬂ Run->Go

This will take the current grid, and solve it, if it is possible to do so. The system will tell you if the
grid entries are illegal (such as the same number in a row or column). If the puzzle is ambiguous,
then the system will produce the first solution it comes to. See the discussion for further comments
on Sudoku solutions.

This option may be accessed by Alt-R then Alt-G, or by pressing F5.

ﬂRun->Training

This turns on the training mode. This special mode activates the Step button, and allows you to see
the progress of the solution. The Step button is shown below. The way to use training is as follows:
1. Load or enter the puzzle.

2. Activate training by clicking on the Training button. You will see the Step button (green arrow)
become active, and the Exit button will become disabled. Note that you cannot exit whilst
training mode is enabled.

3. Press the Run button (red arrow). Some numbers will appear in the grid. Press the Step
button, and some more numbers will appear. You can step through the entire puzzle, until
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'‘Done!" shows as the status message.
4. Training mode is automatically disabled when the puzzle is completed.

The Step button looks as so: ﬂ
The training mode is limited; please see the discussion for details.

The training mode option may be accessed by Alt-R then Alt-T, or by pressing F11.

The Mail Menu

There are three items in this menu. These provide eMail support, allowing you quickly to send off
solutions (or even puzzles) to friends or magazines (especially in the latter case, where there may
be prizes involved).

2| \ail->Set up eMail

This gives you access to the eMail Template System. This allows you to set up your templates for
eMailing puzzles and solutions.

This may be accessed by Alt-M then Alt-U, or by pressing F6.

@ Mail->Send eMail

This option will take all your eMail template information, and the header information in the header
section, and adds the puzzle or solution that is being displayed in the grid. It then mails it using its
own SMTP client to the recipient(s) nominated in the header. Please note that you must be
connected to the SMTP server (usually either by dial-up or some form of DSL) before selecting this
option as it will time out after 15 seconds.

You can access this with Alt-M then Alt-N, or by using F7.

Mail->Save eMail Text

This will combine your eMail template information with the grid information to produce a completed
text message, which can be saved as a file. This is provided for people who are not using an
SMTP mail system: the text can quickly be pulled into a mail and sent off.

This can be accessed with Alt-M and then Alt-V, or by using F8.

The Help Menu

This just provides two options, which allow access to helpful information.

ﬂ Help->Help

Calls up this help file.
This can be accessed with Alt-H and Alt-H, or by pressing F9.
Help->About

This just shows a box with some basic program details. This menu option does not have a speed
button.
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2.3  The Entry and Results Grid

The grid is the middle part of the solver screen, which looks as follows:
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It basically represents the standard Sudoku grid. A zero in a cell means that there is nothing in it: it

is the same as a blank. The system is set up so that you cannot enter anything except a numeric
digit into the cells.

When you are entering the puzzle, you can enter the data in two ways:

1. You can move from cell to cell using the Tab key. When you arrive in a cell you will find the
digit highlighted. Simply type the digit you want, and then tab on to the next field. If you tab
straight through the digit in the cell will remain unaltered. Shift-Tab will move you backwards
through the cells.

2. You can highlight any digit using the mouse and right-click button, and then type in a new digit.

When you have entered a puzzle, you can then save it, using the save option. This will save the
grid as you see it. Thus the usual way to use these options is to enter the puzzle, save it, solve it by
running the solution process, and then save the result. You can also save intermediate results
between steps in the training mode.
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3 Th

e eMail Template System

3.1 The eMail Template Screen

When you select the Mail->Set up eMail menu option on the solver screen, you will be taken to the
eMail template form. This looks as follows:
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This screen is made up of the following:
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The

There is a menu.

Below this, there is a group of quick access speed buttons.
There is a header section, which has six fields.

There is a text section.

There is then a second text section.

menu and buttons are discussed elsewhere; here we discuss the fields. These all act as

templates for your puzzle solution messages.

The eMail Header Section

This comprises six fields:

1.

4,
5.

The first is the Mail Host name (or IP address). This will usually be something like
smtp.hostname.com or smtp.hostname.co.uk. This field must be filled in, as it is how the eMail
gets sent to the host.

The second field is the user name field, and the third is the password. These fields are
optional: they are only needed when your SMTP server requires authorization. Most do not.
The fourth field is the To: field. You must enter the full mail address of the person (something
like name@host.com). You may put in more than one mail address, separating them with
commas.

The fifth field is the From: address. You should put in your mail address here.

The sixth and last field is the Subject field: what the recipient will see as the mail subject.

The Text Sections

There are two text sections. One will be placed before the grid information, and the other after the

grid

information. The idea is that you can have a brief introduction, then the puzzle answer, and

then your signature. This is especially designed for competitions.

How it all Works
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3.2

All the information you put into the sections is saved in template files. You then do not have to
update them unless you want to: the system is designed for a regular competition that you might be
entering. You can then do a puzzle, and eMail it just by hitting the Send eMail button. The
information will be taken from the templates and the grid, which is holding the solution, and will be
sent off via the SMTP client. Alternatively, you can just generate the text message and then pull it
into another mail client and send it. In this latter case no part of the header template is used in the
text message.

The system is designed to be quick to use. Having set up the templates for a regular competition,
you can just enter the Sudoku puzzle, run the solution process and then eMail the answer to the
predefined address.

The Menu and Buttons

The template screen has a few menus and buttons. In all but one case the menu entries have a
matching speed button and quick access methods.

The File Menu

The file menu has four options, described in this section.

File->New Header

This will clear down the top six header fields, from Mail Host to Subject. This is for when you want
to set up a new template. Note that the system will only maintain one template at a time.

You may also access this with Alt-F and Alt-H, or by pressing F11.

O] File->New Text

This will clear down the bottom two text fields. Again, this is for when you want to set up new text in
the template.

You may also access this with Alt-F and Alt-T, or by pressing F12.

% File->Save

This will save all updated information to the templates. Note that your will not be asked for a file
name: the templates are special files that the system keeps track of.

You can access this option with Alt-F and Alt-S, or with F3.

M File->Return

This will return you to the solver screen. If you have changed any of the information in the fields
you will asked if you wish to discard the changes.

You can access this option with Alt-F and Alt-R, or with F4.

The Help Menu

This just provides two options, which allow access to helpful information in exactly the same way
as in the solver screen.

ﬂ Help->Help

Calls up this help file.

© 2004, 2005 DeadMan's Handle Ltd
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This can be accessed with Alt-H and Alt-H, or by pressing F9.

Help->About

This just shows a box with some basic program details. Note that this is the only menu option on
this form that does not have a speed button.
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4.2

Discussions

Sudoku Solutions

This topic briefly discusses how the DeadMan's Handle Sudoku Solver functions.

When you input a puzzle, the system first scans it to ensure there are no obvious errors (such as
two numbers the same in a row, column or 3x3 box). It will generate a message if there are.

The system will then attempt to solve the puzzle deterministically. For most puzzles this will yield
the solution. For some puzzles the deterministic capability produces no further progress, either
because the puzzle has more than one solution or because it is very subtle. At this point the
system does a structured exploration of solutions, looking for inconsistencies until the solution is
found.

If a solution is possible, then the system will find it almost instantaneously on a modern machine
(unless in training mode). If there is more than one solution possible, then the system will return
the first solution it finds (as an experiment, run the solver with all zeros in the grid).

If a solution is not possible, then the system will determine that it cannot find a solution. It will return
a partially completed grid which will still have some zeros in it, and will generate a warning
message. Note that it is possible for the system's initial checks not to be able to identify a problem
with a puzzle: it only appears in the solution attempt. As an example, consider the following partial
fragment of a problem (this is an artificial example):
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Because of the row and column rules, with the positioning of the fives and the one, there is no
possible place for a five in the top-right 3x3 box, which is impossible according to the relevant
Sudoku rule. However, there is nothing in the positioning of the fives and ones that is obviously
contradictory (ie no two fives are in the same row). It is in such cases that the system will come
back with an incomplete grid and a warning message.

Training Mode

The training mode is a mode where you can see the solution being produced in steps. However,
Version 1.3 should be regarded as an evolutionary stage for the training mode - it will be improved.

Once you have activated the training mode you still have to start the solution by pressing Run (the
red arrow). The solution will then advance in stages as you press the Step button (green arrow). It
is important to note the following:

1. Asyou step through, more than one number may be added to the solution grid. Currently,
each 'step’ covers one cycle of Sudoku Solver's application of rules; however, each cycle may
fix more than one number.

2. Stepping only works while Sudoku Solver is in 'deterministic' mode: when it is able to exactly
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calculate missing numbers. In certain puzzles Sudoku Solver has to start guessing (what we
call 'hunt' mode) - at this point it will run through to completion, as tracking what is going on in
hunt mode can become very confusing.

3. You should step through until you see the 'Done!" indicator.

4. Training mode is always turned off again once a puzzle has been solved.

© 2004, 2005 DeadMan's Handle Ltd
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5.1

5.2

Licences

Sudoku Solver Licence

The following is the licence for the Sudoku Solver.

1. Usage. You may install and use the software on any number of machines. You may copy and
distribute the software as long as: (1) no charge is made except for costs in reproducing the
software; (2) you do not modify or alter any part of the program, documentation or distribution
kit.

2. Copyright. DeadMan's Handle Ltd owns the title, copyright, and other intellectual property
rights in the software.

3. Warranty disclaimer. The software and media are provided as seen, without warranty of any
kind. To the maximum extent permitted by applicable law, DeadMan's Handle Ltd disclaims all
warranties and conditions, either express or implied, including but not limited to, implied
warranties and conditions of merchantability, fithess for a particular purpose, and non-
infringement with respect to the software, its output, and media.

4. Limitation of Liability. DeadMan's Handle Ltd accepts no responsibility for any damage and/or
loss to your data or computer system that may result from the use of the software except to the
extent required by law.

Indy Components Licence

The Sudoku Solver uses the Indy components. We are required to include the following as the Indy
components licensing information.

Indy BSD License
Copyright

Portions of this software are Copyright (c) 1993 - 2003, Chad Z. Hower (Kudzu) and the Indy Pit
Crew - http://www.IndyProject.org/

License

Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

e Redistributions of source code must retain the above copyright notice, this list of conditions
and the following disclaimer.

e Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation, about box and/or other
materials provided with the distribution.

e No personal names or organizations names associated with the Indy project may be used
to endorse or promote products derived from this software without specific prior written
permission of the specific individual or organization.

THIS SOFTWARE IS PROVIDED BY Chad Z. Hower (Kudzu) and the Indy Pit Crew "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
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